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Read through this operating manual carefully before use and become familiar with the machine. 
Installation and start-up should not be carried out before reading and understanding this 
document. Keep this manual readily available so that you can reference it as needed. 
 

1.1  What Is the Purpose of this Operating Manual? 
This manual serves as an aid for the installation and operation of the product and supports the 
technical staff with all operating and maintenance tasks to be performed. Furthermore, this 
manual is aimed at preventing dangers to life and health of the user and third parties. 
 

1.2  Who Is this Operating Manual Targeted to? 
The operating manual provides a code of conduct for personnel tasked with the set-up, 
operation, maintenance, and repair of gas engines. A certain level of technical knowledge with 
respect to the operation of gas engines and basic knowledge of electronic ignition systems are 
necessary. Persons who are only authorized to operate the gas engine shall be trained by the 
operating company and shall be expressly instructed concerning potential hazards. 
 

1.3  Which Symbols Are Used in the Operating Manual? 
The following symbols are used in this manual and must be observed: 

 

Example 

This symbol indicates examples, which point out necessary handling steps 
and techniques. In addition, you receive additional information from the 
examples, which will increase your knowledge. 

   

 

Notice 

This symbol indicates important notices for the user. Follow these. In 
addition, this symbol is used for overviews that give you a summary of the 
necessary work steps. 

   

 

Warning 

This symbol indicates warnings for possible risks of property damage or 
risks to health. Read these warning notices carefully and take the 
mentioned precautionary measures. 

   

1 GENERAL INFORMATION
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Danger 

This symbol indicates warnings for danger to life, especially due to high 
voltage. Read these warning notices carefully and take the mentioned 
precautionary measures. 

  
 

1.4  Which Abbreviations/Acronyms Are Used in the Operating Manual? 
In the manual or the user interface, the following abbreviations/acronyms are used. 

Abb. Term Description Explanation 

CAN bus Controller Area 
Network Bus 

Bus for control devices/ 
networks 

Asynchronous serial 
connection system for 
networking control devices 

CE Conformité 
Européenne 

Conformity with EU 
directives 

Mark based on EU legislation 
for certain products in 
conjunction with product safety

CPU Central Processing 
Unit 

Central processing unit 

DC Direct Current Direct Current

EMC Electromagnetic
Compatibility 
 

Compatibility of electrical or 
electronic equipment items 
with their surroundings 

ESD Electrostatic 
Discharge 

Electrostatic Discharge 

ITB Integrated Throttle 
Body 

Throttle with integrated 
stepper motor card 

LED Light Emitting Diode Light emitting diode Light emitting electronic semi-
conductor 

MICT MOTORTECH 
Integrated 
Configuration Tool 

Configuration software for 
MOTORTECH control units 

TG Throttle Gear Throttle gear

USB Universal Serial Bus Serial wiring system to connect 
a computer to external 
equipment 
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2.1  General Safety Instructions 
MOTORTECH equipment is manufactured as state of the art and therefore safe and reliable to 
operate. Nevertheless the equipment can cause risks or damages can occur, if the following 
instructions are not complied with: 

– The gas engine must only be operated by trained and authorized personnel. 

– Operate the equipment only within the parameters specified in the technical data. 

– Use the equipment correctly and for its intended use only. 

– Never apply force. 

– For all work, such as installation, conversion, adaptation, maintenance, and repair, all 
equipment must be disconnected from the power supply and secured against unintentional 
restarting. 

– Perform only such maintenance and repair work as is described in this operating manual, 
and follow the instructions given while working. For maintenance of the equipment, only use 
spare parts supplied by MOTORTECH. Further work must only be performed by personnel 
authorized by MOTORTECH. Non-compliance with the instructions will void any warranties 
for the proper function of the equipment as well as the responsibility for the validity of the 
certifications. 

– Safety devices must not be dismounted or disabled. 

– Avoid all activities that can impair the function of the equipment. 

– Operate the equipment only while it is in proper condition. 

– Investigate all changes detected while operating the gas engine or ignition system. 

– Ensure compliance with all laws, directives and regulations applicable to the operation of 
your system, including such not expressly stated herein. 

– If the system is not entirely tight and sealed, gas may escape and lead to an explosion 
hazard. Upon completion of all assembly works, always check the system's tightness. 

– Always ensure adequate ventilation of the engine compartment. 

– Ensure a safe position at the gas engine. 
 

2 SAFETY INSTRUCTIONS
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2.2  Electrostatic Discharge Hazards 
Electronic equipment is sensitive to static electricity. To protect these components from damage 
caused by static electricity, special precautions must be taken to minimize or prevent 
electrostatic discharge. 

Observe these safety precautions while you work with the equipment or in its vicinity. 

– Before performing maintenance or repair work, ensure that the static electricity inherent to 
your body is discharged. 

– Do not wear clothing made from synthetic materials to prevent static electricity from 
building up. Your clothing should therefore be made of cotton or cotton mix materials. 

– Keep plastics such as vinyl and Styrofoam materials as far away from the control system, the 
modules, and the work environment as possible. 

– Do not remove the circuit boards from the housing of the device. 
 

2.3  Special Safety Instructions for the Device 
  

 

Explosion hazard! 

When the system is powered up, do not remove any connectors unless the 
system is not located in a potentially explosive atmosphere. 

   

 

Explosion hazard! 

If the system is not entirely tight and sealed, gas may escape and lead to an 
explosion hazard. Upon completion of all assembly works, always check the 
system's tightness. Also ensure that the gauge port on the VariFuel2 is 
closed. 

All works involving gas-carrying parts must be executed by trained 
personnel only. 

   

 

Operational safety! 

All screws of the connectors must be adequately tightened. 
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Risk of destruction due to electrostatic discharge! 

The VariStep stepper motor card may only be installed by specialized 
personnel who has been trained in handling ESD sensitive components and 
with due regard to relevant ESD standards. It must be installed into a 
control cabinet, and it is necessary to comply with the ESD standard 
DIN EN 61340-5-1; VDE 0300-5-1:2008-07. 

Damages caused by electrostatic discharge are not covered by the 
guarantee. 

   

 

Risk of burning! 

The surfaces of the system may heat up to high temperatures. 

   

 

Risk of damage! 

The stepper motor of the VariFuel2 is not suitable for carrying or lifting a 
gas mixer. There is a danger that the stepper motor could break, and if the 
gas mixer were to fall, it could result in injury or property damage. 

Always carry or lift the gas mixer by its exterior housing. 

  
 

2.4  Proper Disposal 
After the expiration of its service life, MOTORTECH equipment can be disposed of with other 
commercial waste, or it may be returned to MOTORTECH. We will ensure its environmentally 
friendly disposal. 
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3.1  Functional Description 
The VariStep stepper motor card drives the stepper motor of a VariFuel2 gas mixer or throttle. 
This stepper motor carries out position changes: 

– In the VariFuel2 gas mixer the stepper motor changes the openings of the fuel ring and 
thereby adjusts the composition of the gas-air mix. 

– In the throttles the stepper motor changes the opening angle of the throttle and thereby 
controls the supply of the gas-air mix. 

Control can be manual or automatic. Manual adjustments can be made using buttons on the 
stepper motor card or via a connected PC. In automatic mode, digital or analog input signals, 
such as those provided by a master control, are analyzed. In addition, connection to the 
aggregate control ALL-IN-ONE via CAN bus is possible. 

The stepper motor card is configured using a connected PC. The software used for this purpose 
is also used to display current system data and error messages. 
 

3.2  Applications 
The VariStep stepper motor card can be used for the following MOTORTECH devices. 

– VariFuel2 gas mixer with stepper motor 

– ITB throttles with integrated stepper motor 

– TG throttle gears 

If several devices which are to be controlled via the VariStep stepper motor card are to be used 
in one system, several stepper motor cards are needed. An additional splitter is not necessary. 

Any use other than the one described in the operating manual shall be considered improper use 
and will result in the voiding of all warranties. 

3 INTENDED USE
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System Overview (Example) 

 

 VariStep stepper motor cards Engine 

 VariFuel2 gas mixer Wiring rail (ignition) 

 ITB throttle with integrated stepper motor Gas supply 

 SC100 speed control Gas train 

    Air supply 

    Air filter 
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4.1  Technical Data 

4.1.1 Certifications 
The stepper motor card is certified in accordance with the following standards: 

CE 
– EMC Directive 2004/108/EC 

– Emission standard for industrial environments as per DIN EN 61000-6-4:2007 

– Immunity for industrial environments as per DIN EN 61000-6-2:2006 

 

4 PRODUCT DESCRIPTION
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 DECLARATION OF CONFORMITY 

The company: MOTORTECH GmbH
Hogrevestrasse 21-23 
29223 Celle 

declares that the products: VariStep stepper motor card

intended purpose: use with gas Otto engines

complies with the provisions of the following EC Directives: 

 EMC Directive 2004/108/EC

under consideration of the following standards:

 DIN EN 61000-6-4:2007
DIN EN 61000-6-2:2006 
DIN EN 61000-4-2, DIN EN 61000-4-3 
DIN EN 61000-4-4, DIN EN 61000-4-5 
DIN EN 61000-4-6, DIN EN 61000-4-8 

The marking of the product is: P/N 31.01.955

 

This declaration is submitted by:

Name: Florian Virchow 
 

Position in company: Managing Director

  

  

  

Celle, dated 16.02.2011 

Place, date 
 

Legally binding signature 
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4.1.2 Mechanical Data 
The stepper motor card has the following mechanical characteristics: 

Feature Value 

Dimensions 217 x 128 x 50 mm (8.54 x 5.04 x 1.97")

(length x width x height) 

Weight 655 g (1.44 lbs)

Shape of device See chapter Overview Drawings on page 19

Mechanical Environmental 
Conditions 

Protection: IP20

Climatic Environmental 
Conditions 

-15 °C to 55 °C (5 °F to 131 °F)

85 % relative humidity, max. without condensation 
up to 2000 m (6561') above sea level 

 
 

4.1.3 Warning Notices on the Device 
Top of Device 
 

Warning Meaning 

 

Component subject to electrostatic hazards

WARNING! Read and understand the 
installation and operating manual prior to 
installing or making any adjustments. Do not 
disconnect equipment unless power has 
been switched off. 

WARNING: Read and understand the
installation and operating manual prior to 
installing or making any adjustments. No 
connections to components may be 
separated under voltage. 
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4.1.4 Product Identification – Labeling on the Device 
The numbers required for unique product identification are on the device: 

Top of Device 

 

Bottom of Device 

 

 

Abb. Meaning 

P/N Product number of the stepper motor card

S/N Serial number of the stepper motor card

 
 

4.1.5 Electrical Data 
The stepper motor card has the following electrical characteristics: 

Feature Value 

Power consumption Max. 31 W

Supply voltage 18 to 32 V DC

Required current Max. 1,7 A

Internal fuse 3,15 A, delay, 5x20 mm, exchangeable
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Electrical Data for Inputs and Outputs 
The inputs and outputs of the stepper motor card have the following electrical data:  

Inputs and outputs Values/characteristics 

Digital inputs – Galvanically isolated

– Input voltage up to 32 V DC 

– Input current at least 5 mA for high level  

– Save low level:  
Voltages below 1.0 V DC for at least 30 μs  

– Save high level:  
Voltages above 4.5 V DC for at least 5 μs 

Diagram of the Signal 

 

When the reset signal is given, the high level must be present 
at the relevant input for at least 50 ms before it is possible to 
initiate the reset. 

Digital outputs – Galvanically isolated

– Low level: output is high-impedance 

– High level: output is low-impedance 

– Switching voltage: maximum 32 V  

– Current: maximum 500 mA 

Analog voltage inputUin) Permissible voltage: 0 to 10 V 

Input resistance: 12,4 kΩ 

Analog current input Iin) Permissible current: 0 to 20 mA

Max. difference in potential relative to device ground: +/-15 V  

Input resistance: 10 Ω 
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Inputs and outputs Values/characteristics 

Analog voltage output 
(Uout) 

Output voltage: 0 to 10 V

Working resistance: min. 300 Ω 

Analog current output 
(Iout) 

Output current: 0 to 20 mA

Working resistance: max. 300 Ω 

 
 

4.1.6 Interfaces 
USB 
– Compatible with USB 1.1 and USB 2.0 

– The connector type B is only suitable for temporary data exchange and not for a permanent 
connection. 

CAN Bus 2.0B Interface 
– As per ISO 11898, up to 1 MBit/s 

– Transient-proof (automotive classification) 

– Max. 110 participants 
 



 
 

Rev. 11/2014 19 

4.1.7 Overview Drawings 
Ports/Connections and LEDs 

 

Designation Function 

Digital Inputs Digital inputs via which position changes of the stepper motor are 
conducted. Beyond that, there is a digital input for a reset signal 
available (see Wiring Digital Inputs on page 26). 

Digital Outputs Digital outputs which signal the position of the stepper motor and 
the status of the stepper motor card (see Wiring Digital Outputs on 
page 27). 

Analog 
Inputs/Outputs 

Analog inputs and outputs by means of which you can change and 
resend the position of the stepper motor (see Wiring Analog Inputs 
and Outputs on page 28). 

USB Port for the data transmission to the PC. Data transmission is 
signaled by the blinking LEDs TXD and RXD  (TXD=Data are being 
sent, RXD=Data are being received). 

CAN Port for communication via CAN bus with master control ALL-IN-
ONE. Data transmission is signaled by the blinking LEDs TXD and 
RXD  (TXD=Data are being sent, RXD=Data are being received). 
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Designation Function 

Modbus (RS485) 
(not yet available) 

Port for communication via Modbus with superordinate control 
devices. Data transmission is signaled by the blinking LEDs TXD and 
RXD  (TXD=Data are being sent, RXD=Data are being received). 

Open/Close; 
Reset 

In manual mode the stepper motor can be driven via the buttons 
Open and Close  (see Manual and Automatic Operation on page 30). 
In the case of an error, the error can be reset followed by a 
reference run if you press the two buttons simultaneously. 

Auto/Manual Switch for changing between manual and automatic mode (see 
Manual and Automatic Operation on page 30) 

Status LEDs – Power: The LED lights up if sufficient supply voltage is 
available. 

– Status: You can find details about status signaling in the 
following information box. 

– flashes green 
The stepper motor card is working without any errors. 

– flashes orange 
A warning has occurred. 

– flashes red 
An error has occurred. 
(see Runtime Data – Errors on page 59). 

– Auto: The LED lights up if the stepper motor card is in automatic 
mode and is controlled by the signals of the master control.  

– Manual: The LED lights up if the stepper motor card is in 
manual mode. 

Power IN Connection for the supply voltage (see Wiring Power Supply on 
page 23) 

Stepper Motor + 
Encoder 

Port for the stepper motor and the encoder. The LEDs Motor Activity
flash if the stepper motor moves (see Wiring Stepper Motor and 
Encoder on page 24). 

Fuse Replaceable fuse (3.15 A)
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Status signaling 

The status of the VariStep stepper motor card is signaled via the LED Status.

– Error-free operation: flashes green 

– Warning: flashes orange 
Warnings are reset by a reference run or by downloading a 
configuration to the device. For example, warnings are triggered by: 

– VariStep stepper motor card is unconfigured. 

– Device connected was changed. 

– Over-temperature or over current error confirmed by MICT. 

– Error: flashes red 
Error can be confirmed via MICT, simultaneously pressing button Open 
and Close or by the external reset signal. Errors can for example be 
caused by: 

– Step Loss 

– Over temperature 

– Low voltage 

– Over current 
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5.1  Installation Instructions 
Unpack the stepper motor without damaging it and ensure that the operating manual is always 
within reach of the device and easily accessible. Installation locations where strong vibrations 
or ambient temperatures of below -15 °C (5 °F) or above +55 °C (+131 °F) are present are not 
permissible and result in the warranty being voided.  

  

 

Risk of damage! 

The device must not be installed directly on or at the engine, as vibration 
and heat may cause damage to electronic components. 

   

 

Risk of damage! 

Make sure that the device is not covered and ensure sufficient circulation 
of air. 

   

 

Risk of destruction due to electrostatic discharge! 

The VariStep stepper motor card may only be installed by specialized 
personnel who has been trained in handling ESD sensitive components and 
with due regard to relevant ESD standards. It must be installed into a 
control cabinet, and it is necessary to comply with the ESD standard 
DIN EN 61340-5-1; VDE 0300-5-1:2008-07. 

Damages caused by electrostatic discharge are not covered by the 
guarantee. 

  

Scope of Supply 
The VariStep stepper motor card as supplied consists of the following components: 

– VariStep stepper motor card 

– CD-ROM 

– USB cable 

– Operating manual 

Installation of the VariStep stepper motor card 
1. Install the VariStep stepper motor card on a DIN rail in the panel. 

2. Fix the card using the attachment screws on the sides. 

5 INSTALLATION INSTRUCTIONS
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6.1  Wiring Power Supply 
The power supply is wired using the 3-pole plug. 

 

Variations 

1 Battery Generator Control Unit

 

2  Supply voltage

 

3  Battery Charger
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6.2  Wiring Stepper Motor and Encoder 
  

 

Risk of damage! 

To rule out the possibility of moving the devices connected out of the 
control area, observe the following procedure when connecting the stepper 
motor to the VariStep stepper motor card: 

1. Configure the VariStep stepper motor card for the device type desired 
(see section External Device on page 46). 

2. Separate the stepper motor card from the power supply. 

3. Connect the stepper motor of the VariFuel2 gas mixer or the throttle to 
the stepper motor card. 

4. Connect the VariStep stepper motor card again to the power supply. 

▸ Now, the stepper motor card will initiate a reference run. The device 
is ready for operation. 

  

Wiring via the 11-pole plug on the stepper motor card. The length of the connecting cable must 
not exceed 10 m (32'). 

 

 
 
Encoder 

 
 
Stepper motor 
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Pin assignment when using the original MOTORTECH wiring harness: 

PIN stepper- 
motor card Description Pin stepper motor 

and encoder 
Wire color/ 
designation 

1 Encoder ground J brown

2 Encoder 5V supply voltage I yellow

3 Encoder A E white

4 Encoder B F green

5 Encoder I (index) G gray

6 Encoder earth H shield

7 Stepper motor phase B2 D 4

8 Stepper motor phase B1 C 3

9 Stepper motor earth H shield

10 Stepper motor phase A2 B 2

11 Stepper motor phase A1 A 1
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6.3  Wiring Digital Inputs 
The digital inputs are wired using the 10-pole plug. The inputs can be switched both on the side 
of the operating voltage and on the ground side. 

 

Pin Designation Function 

1 DIRin + The level on the digital input indicates the direction towards which 
the fuel ring of the VariFuel2 or the throttle is moved if there are 
pulse signals on the STEPSin input (see Inputs / Outputs – Control 
Setup on page 49). 

2 DIRin - 

3 STEPSin + Pulses on the input adjust the fuel ring of the VariFuel2 or the 
throttle in steps (see Inputs / Outputs – Control Setup on page 49). 4 STEPSin - 

5 POS1in + If a high level is applied, position 1 as defined in the configuration 
is approached. 6 POS1in - 

7 POS2in + If a high level is applied, position 2 as defined in the configuration 
is approached. 8 POS2in - 

9 RESETin + If a high level is applied for at least 50 ms, the device exits the error 
mode and the stepper motor card is reset. Subsequently, it initiates 
a reference run. 10 RESETin - 
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6.4  Wiring Digital Outputs 
The digital outputs are wired using the 12-pole plug. The outputs can switch both the operating 
voltage and the ground. 

 

Pin Designation Function 

11 ERRORout + The output is low-resistance if an error has occurred and the stepper 
motor card is in automatic mode. To exit the error state, the error needs 
to be acknowledged (refer to Acknowledging Faults on page 71). 12 ERRORout - 

13 CLOSEout + The output is low-resistance if the stepper motor has reached the 
closed position. 14 CLOSEout - 

15 OPENout + The output is low-resistance if the stepper motor has reached the open 
position. 16 OPENout - 

17 POS1out + The output is low-resistance if the stepper motor has reached the 
configured position 1. 18 POS1out - 

19 POS2out + The output is low-resistance if the stepper motor has reached the 
configured position 2. 20 POS2out - 

21 OFFLINEout + The output is low-resistance if the stepper motor card is in a state in 
which it does not react to external control signals (e. g. manual mode or 
reference run). 22 OFFLINEout - 
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6.5  Wiring Analog Inputs and Outputs 
The analog inputs and outputs are wired using the 14-pole plug. 

 

Pin Designation Function 

23 Uin + Voltage input, via which the fuel ring of the VariFuel2 or throttle 
can be adjusted (see Inputs / Outputs – Control Setup on 
page 49). 

24 Uin GND 

25 Iin + Current input, via which the fuel ring of the VariFuel2 or throttle 
can be adjusted (see Inputs / Outputs – Control Setup on 
page 49). 

26 Iin - 

29 Uout + Voltage and current output with shared ground. The outputs 
provide the current position of the fuel ring of the VariFuel2 or 
throttle as corresponding signal. 

30 Uout/Iout GND 

31 Iout + 
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Unused inputs and outputs 

Note that the terminals for the analog inputs and outputs not selected in 
the MICT must remain unoccupied. 

  
 

6.6  Wiring CAN Bus 
The CAN bus interface is wired using the 4-pole plug. 

  First device Second-to-last device

 
   Second device Last device

  

 

CAN bus wiring 

Note the following when connecting the CAN bus: 

– There can be a maximum of 110 devices connected to one CAN bus. 

– The maximum wire length is 250 m (820') depending on the transfer 
rate. 

– Each bus end must be fitted with a terminating resistor of 120 Ω (see 
drawing). 
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7.1  Manual and Automatic Operation 
Adjusting the opening of the throttle or the openings in the fuel ring of the VariFuel2 can be 
carried out via the stepper motor card in two operation modes: 

– Manual operation 

– Automatic operation 

You can switch between manual and automatic mode using the switch Auto/Manual or via the 
MICT. In this case, the MICT overwrites the switch position on the device. Switching via the 
button Auto/Manual can be blocked by a setting in MICT. Illumination of the status LEDs Manual 
or Auto indicates in which operation mode the stepper motor card is at the moment. 

Manual Operation 
In manual operation, the external input signals of the master control are ignored. You can 
change the position of the throttle and fuel ring of VariFuel2 using the two buttons Open and 
Close . The stepper motor card must also be in manual operation for configuration via the MICT 
and for transferring settings to the device. 

  

 

Risk of damage! 

In manual operation, the signals of the master control are not analyzed. If 
you make any adjustments in the manual mode with the gas engine 
running, make sure that these settings do not endanger the correct 
operation of the gas engine. 

  

Automatic Operation 
In automatic operation, the stepper motor card evaluates the external input signals of the 
control unit connected. The buttons Open and Close are deactivated. The device cannot be 
configured via the MICT. In automatic operation, the MICT can only be used to display the data 
and to create log files. 
 

7.2  Reference Run 
After the device is switched on or was reset, the VariStep stepper motor card initiates a 
reference run. This means that the stepper motor determines its current position. In automatic 
mode, the stepper motor subsequently approaches the position defined by the master control. 
In manual mode the device connected initially remains in the following position: 

– VariFuel2 gas mixer remains in the open position. 

– Throttles remain in the closed position. 

During the reference run the output OFFLINEout is low resistance and the corresponding LED 
lights up. The signals of the inputs are not analyzed. A reference run can also be triggered via 
the MICT. 
 

7 FUNCTIONS 
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7.3  Open/Closed Positions 
The Open and the Close position are specified as follows: 

– Open: Throttle or fuel ring of the VariFuel2 is completely open (100 % open) 

– Closed: Throttle or fuel ring of the VariFuel2 is completely closed (0 % open) 

When one of these positions is reached, the relevant digital output OPENout or CLOSEout will be 
switched and the relevant LED lights up. The connected devices cannot be moved beyond these 
two positions and all corresponding signals are limited. 
 

7.4  Configurable Opening Angles (Position 1 and 2) 
Two opening angles are configured via the MICT, which can be driven directly via digital inputs 
(POS1in, POS2in). If the signals POS1in and POS2in are simultaneously present, position 1 is 
driven. When the stepper motor reaches one of the two positions, the relevant digital output 
(POS1out, POS2out) is switched and the corresponding LED lights up. In this way, you can define 
the opening angles for certain operating states such as starting or purging the gas engine. 

You can configure positions 1 and 2 with the MICT. Positions – Values on page 52. 
 

7.5  Change of Opening Angles via Digital and Analog Inputs 
In automatic mode the opening angle can be controlled directly via the following inputs. 

– Digital inputs DIRin and STEPSin 

– Analog voltage inputUin 

– Analog power input Iin 

– Field bus CAN 

Depending on which master control you are using, you can select the required input using the 
MICT. If one of both end positions (open or closed) has been reached, the signals are limited at 
the inputs in the corresponding direction. 

You can configure the inputs with the MICT. Refer to the section Inputs / Outputs – Control Setup 
on page 49. 
 

7.6  Analysis of Positions via Analog Outputs or Field Bus 
The current position of the throttle or the fuel ring of the VariFuel2 can be sent to the master 
control via an analog voltage output or an analog current output or a field bus. Using the MICT, it 
is possible to configure which of the two outputs is to be used and which voltage or current 
value corresponds to the Open or Close position. The current or voltage applied on the output is 
then determined accordingly proportional to the current opening angle. 

You can configure the outputs with the MICT. Refer to the section Inputs / Outputs – Control 
Setup on page 49. 
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7.7  Access Control 
You can protect the VariStep stepper motor card against unauthorized access by establishing 
the access control in the MICT. The access control has four operating levels, three of which can 
be secured with different PINs. As a default setting, the access control is not activated. If the 
access control for the stepper motor card is activated, it is independent from the access levels 
that control the views within the MICT.  

  

 

Access Control 

A user is logged in to the Advanced Service access level on the MICT. He 
changes a configuration and would like to download the latter to the 
stepper motor card. Although he has the full authorization set in the MICT, 
he is prompted to log in with the PIN for the Level 3 (Master). This ensures 
that it is not possible for any user with an MICT and the generally valid 
password to change the configuration of your stepper motor card. 

  
Various functions are at your disposal on the four operating levels. The figure below illustrates 
this: 
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The following functions are available on the different levels: 

– Level 0 (Read Only) 
Enables read only access for all users. 

– Level 1 (Operator) 
At this level the user can make position changes (closed and open position, position 1 and 
position 2, and make manual changes to the opening). Beyond that, he can change the 
operation mode and can confirm errors. 

– Level 2 (Service) 
The service personnel can also initiate a reference run and reset the maximum step losses 
within the runtime data. 

– Level 3 (Master) 
At this level, the master can also reset all PINs and activate and deactivate the access 
control. Moreover, only the master is authorized to download a changed configuration to the 
stepper motor card. 

For information on the access levels in the MICT, please refer to the section Access Levels in the 
MICT on page 35. 
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MICT is an abbreviation for MOTORTECH Integrated Configuration Tool. You configure your 
VariStep stepper motor card via the MICT and can adjust it to the master control and the device 
connected (gas mixer or throttle). 
 

8.1  MICT System Requirements 
For the installation of the MICT, the following minimum requirements must be fulfilled: 

– x86-compatible PC, at least performance class Intel Pentium 4 with 2 GHz 

– 128 MB free RAM 

– 100 MB free disk space 

– USB interface 1.1 or higher 

– Display with minimum XGA resolution (1024 x 786 pixels) 

– Microsoft Windows XP, Windows 7 
 

8.2  MICT Installation 
The software for the installation of the MICT is on the CD-ROM enclosed with the VariStep 
stepper motor card.  

To install the MICT, proceed as follows:  

1. Start the installation. 

– CD-ROM as installation medium 
Insert the CD-ROM in the CD/DVD drive of your PC. If the Autorun function is activated for 
the drive, the installation will start automatically. If the function is disabled for the 
drive, the installation routine can be started with the file setup.exe from the CD-ROM 
directory. 

– Alternative 
Copy the installation routine setup.exe to your PC. The installation is started by 
executing the file. 

2. Run the installation. 
Follow the instructions of the installation routine. Please note that the license agreement 
terms must be accepted before using the MICT. If the terms are not accepted, the installation 
cannot continue. 

3. Install the USB driver by executing the file CDMxxxxx_Setup.exe (e.g. CDM20824_Setup.exe). 

▸ You have set up the MICT and can now connect your PC to the stepper motor card via the 
USB interface. 

 

8 SETTINGS VIA THE MICT
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8.3  Access Levels in the MICT 
You can open the MICT via Start -> Programs -> MOTORTECH -> MICT -> MICT on your PC. 

After opening the MICT, select the access level for which you have clearance. The access level 
controls the options you have at your disposal in the MICT. The password required for access 
can be obtained from your MOTORTECH contact person (refer to Customer Service Information on 
page 71). 

 

The following access levels are available: 

– Read Only 
On this level, the user can open a configuration and transfer it to the device. However, he 
cannot make changes to the configuration. The user has read-only access to all other 
settings. 

– Customer 
This level enables the configuration of the basic functions required for operation in addition 
to the read-only function. 

– Service 
This level includes all functions needed for maintenance. 

– Advanced Service 
This level offers full access to all functions of the MICT and is enabled and accessible for 
specially trained personnel only. 

The following sections will describe the options at your disposal with the Advanced Service 
access level. If you have registered for a different level, you cannot execute all functions shown. 
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8.4  Configuration Pages (Overview) 
The configuration pages are divided into the following sections: 

 

 

Item no. Area 

 Menu bar 

 Toolbar 

 Navigation bar 

 Configuration section 

 Status bar 
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The functions in the menu, navigation bar, and the toolbar as well as the configuration section 
will be described in the following. 

The status bar provides you with the following information (from left to right): 

– Status display 
Indicates whether a connection is established with the controller: 

– Green: connection established 

– Red: the connection was interrupted and is being restored 

– Gray: the connection is not established and is not being restored 

– Indication of the interface being used for the connection to the device 

– Indication of the device ID 

– Indication of the access level of the user in the MICT 

– Indication of the operating level for the VariStep if access control has been activated and the 
user has logged on with a PIN. 

– Indication of the MICT program version 
 

8.5  Menu Bar and Toolbar 
The following functions are available to you via the symbols on the toolbar and the entries in the 
menu bar: 

Symbol Menu Function 

 

File -> New Creates a new configuration.

 

File -> Open Opens an existing configuration.

 

File -> Save / 
File -> Save As 

Saves the current configuration.

 File -> Recent Documents The last five configuration files used are offered for 
selection. 

 File -> Close Closes the current configuration.

 File -> Open trace Opens a runtime data record (trace file). Please refer to 
the section Runtime Data on page 55. 

 File -> Open pickup trace Opens a saved recording of pickup signals (putrace 
file), for example from a MOTORTECH ignition 
controller. Pickup signals cannot be recorded by the 
VariStep. 
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Symbol Menu Function 

 

File -> Change Access 
Level 

Changes the access level for accessing the 
configuration data and functions. 

 

File -> Print Prints the current configuration.

 

File -> Print to PDF file Prints the configuration to a PDF file.

 File -> Print Preview Opens a print preview of the configuration.

 File -> Quit Exits the MICT.

 

Device -> Connect Connects to the device.

 

Device -> Disconnect Cuts the connection to the device.

 

Device -> Download to 
device 

Downloads configuration data from the PC to the 
device. This function can only be executed in manual 
mode. 

 

Device-> Upload from 
device 

Uploads configuration data from the device to the PC.

 

Device -> Runtime data Opens the window Runtime data. Please refer to the 
section Runtime Data on page 55. 

 

Device -> Log Opens the window Log (Advanced Service only). Please 
refer to the section Log on page 63. 

 Device -> Select Mode Opens the window Select operation mode in which you 
can select the operation mode. The following modes 
are possible: Manual operation mode, Automatic 
operation mode or Switch controls operation mode. 

 Device -> Manual 
Adjustment 

Opens a window in which you can manually adjust the 
opening angle. 

 Device -> Open Position Completely opens the throttle or the fuel ring of the 
VariFuel2 in manual mode. 

 Device -> Close Position Closes the throttle or the openings of the fuel ring of 
the VariFuel2 in manual mode. 
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Symbol Menu Function 

 Device -> Position 1 In manual mode selects the position 1 set in the 
configuration by a percentage. 

 Device -> Position 2 In manual mode selects the position 2 set in the 
configuration by a percentage. 

 Device -> Reference run Conducts a reference run in manual mode (only Service 
and Advanced Service). 

 Device -> Temperature 
Extremes 

Opens a window in which the maximum and minimum 
temperature are displayed. These values are measured 
throughout the operating time on the board of the 
stepper motor card. 

 Device -> Error 
Acknowledge 

All operating errors are acknowledged.

 Device -> Access Control The setup for the access control to the device is 
described in a separate section. Please read the 
chapter Access Control of the Stepper Motor Card on 
page 41. 

 Device -> Trigger Software 
Reset 

Restarts the device's operating software (only 
Advanced Service). 

 Settings -> Language Opens the window Select Language in which you can 
change the interface language of the MICT. 

 Settings -> Online update 
settings 

Opens the window Online Update Settings. Please refer 
to the section Online Update Settings on page 40. 

 Settings -> Database 
settings 

Opens a dialogue window in various databases can be 
assigned as source for the MICT. 

 Settings -> Temperature 
scale 

Opens the window Select Temperature Scale, in which 
you can change the unit for the temperatures shown in 
the MICT. 

 Settings -> Display by 
cylinders 

This function is available for certain MOTORTECH 
ignition controllers and has no effect in conjunction 
with the VariStep. 

 Document Has no function with the VariStep.

 Tools -> Coils Opens a database with information on MOTORTECH 
ignition coils. 

 Help -> Help Opens the online help function.

 Help -> About MICT Opens detailed information on the MICT.
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8.6  Online Update Settings 
The MICT uses data from a VariFuel database for the configuration. Such data can be updated 
with automatic online updates. The settings for the update can be entered with the following 
entry in the menu bar: 

Settings -> Online update settings 

 

You have the following options: 

– Enable automatic database updates  
Enable and disable the automatic online update using the checkbox. As the default setting, 
the online update is activated and is executed daily (if an internet connection is established) 
at first start-up of the MICT. 

– Use a proxy to access the web 
Using the checkbox, you can activate settings for Internet access via a proxy server, which 
you can then set up by entering http Proxy and Port. 

– Show Log 
Use this button to open a window in which the online updates performed are logged. 

– Update Now 
Use this button to manually start an online update. 

  

 

Online Update 

After the online update, the updated data will only be used if these have 
been downloaded onto the device. However, this requires the relevant 
authorization. 

Whenever the configuration is uploaded from the device, the version of the 
configuration saved in the device will be compared with the version in the 
database. If the two versions are not the same, a window with additional 
instructions will open up. 
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8.7  Access Control of the Stepper Motor Card 
If the access control to the stepper motor card is activated, access to the following areas is 
possible with a PIN only: 

– Troubleshooting 

– Position changes (Open, Close, Position 1 and 2, Manual Adjustment, Reference Run) 

– Configuration (transfer of a configuration to the stepper motor card) 

The access control regulates the accesses to the stepper motor card via the MICT. For 
explanations concerning access control to the stepper motor card and the delimitation of the 
access levels in the MICT, refer to section Access Control on page 32. 

The access control functions can be accessed in the menu bar via: 

Device -> Access Control 
 

8.7.1 Enabling/Disabling Access Control 
   

 

Enabling/Disabling access control 

As a default setting, the access control is not activated, and all PINs are set 
to 0000. Once the access control has been activated, and the PINs were 
changed, these PINs will continue to be used. To activate the access 
controls again, you will need the PIN for level 3 (Master). It is therefore 
recommended to reset all PINs before disabling. 

If that was not done, or a system must be unlocked for another reason, a 
request key can be issued in the MICT. Refer to the section Resetting all 
PINs on page 42. 

  

To enable or disable the access control, proceed as follows: 

1. Open the input dialog via Device-> Access Control -> Enable or Disable Access Control. 

2. Enter the PIN for the level Master (level 3). 

3. Confirm the input with OK. 
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8.7.2 Login/Logout 
If the access control is activated, you are prompted to log in if you want to execute functions that 
are allocated to a specific operating level. In addition, you can log in specifically to an operating 
level via the menu bar. 

To log into a specific operating level, proceed as follows: 

1. Open the input dialog via Device-> Access Control -> Login. 

2. First select the level you wish to log on to. 

3. Enter the PIN for the desired level. 

4. Confirm the input with OK. 

▸ You are now logged into the corresponding level and can execute all functions that are 
allocated to this operating level without having to log in again. 

After completing the log-in, you can log out again as follows: 

Device -> Access Control -> Logout 
 

8.7.3 Changing the PIN 
To change the PIN for a specific operating level, proceed as follows: 

1. Open the input dialog via Device -> Access Control -> Change PIN 

2. First select the level for which you wish to change the PIN. 

3. Enter the current PIN for the desired level. 

4. Enter the new PIN in the two subsequent fields. 

5. Confirm the input with OK. 

▸ The PIN for this operating level has now been changed. 
 

8.7.4 Resetting all PINs 
To reset all PINs, proceed as follows: 

1. Open the input dialog via Device -> Access Control -> Reset all PINs. 

2. If you are not yet logged in to the Master (level 3) level, you will be prompted to log in with 
the relevant PIN. 

3. Accept the input with OK. 

4. To reset all PINs, you will be prompted again to enter the PIN for the level Master (level 3) . 

5. Confirm the input with OK. 

▸ All PINs are now reset to the value 0000. 
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To reset all PINs, you need the PIN for the level Master (level 3). To be able to unlock a system in 
case of emergency that was locked in this way, you have the following option: 

1. In the menu bar, select the entry Device -> Access Control -> Get reset all PINs request key to 
open a window with the same name. 

2. Send the request key with the serial number to your service contact partner at MOTORTECH 
(refer to Customer Service Information on page 71). This key is valid only for the respective 
controller and only for a certain amount of time. 

▸ Your information will be verified, and you will receive an authorization key from your 
contact partner. 

3. Open with the menu entry Device -> Access Control -> Input of authorization keys to reset all 
PINs of the same window name. 

4. Enter the authorization key received in the input field. 

5. Confirm the input with OK. 

▸ If the input was correct, all PINs are reset to the default value 0000. 
 

8.8  Working with Configurations 
To ensure that the VariStep stepper motor card interprets incoming data correctly and converts 
them to the desired control signals, it requires information on the device connected and the 
master control connected. This information is stored in a configuration file on the stepper motor 
card. 

You need the MICT for the following tasks: 

– Creating configuration files 

– Opening configuration files from a data carrier 

– Processing configuration files 

– Saving configuration files on a data carrier 

– Downloading configuration files to a VariStep stepper motor card 

– Uploading configuration files from a stepper motor card 

– Displaying current and saved runtime data  
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8.8.1 Create, Open, Save 

 

Click on the symbol to launch a new configuration and select the entry Stepper 
Motor Cards -> VariStep. 

 

 

Click on the symbol to open a saved configuration.

 

 

Click on the symbol to save the configuration currently displayed in the MICT to 
a data carrier. 
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8.8.2 Upload, Download 

 

Click the symbol to upload the current configuration from the VariStep stepper 
motor card to the MICT. If applicable, the MICT first establishes a connection to 
the stepper motor card connected. 

 

Click the symbol to download the configuration set in the MICT to the VariStep 
stepper motor card. This function can only be executed when the stepper motor 
card is in manual mode. This action overwrites the existing configuration of the 
MICT. If applicable, the MICT first establishes a connection to the stepper motor 
card connected. 

   

 

Existing configuration is cleared! 

If you download a configuration to a VariStep stepper motor card, the 
previously used configuration is deleted and the new settings are 
immediately implemented. 

  
 

8.8.3 Compatibility Information 

 

If you upload a configuration from the VariStep stepper motor card to the MICT that does not 
correspond to the status of your MICT, or if you open this type of configuration in the MICT, the 
following situations may occur: 

– No values are present in the configuration for certain MICT functions. The MICT assumes the 
standard values for these functions. 

– The configuration contains function values that are not supported by the MICT. 

The following situations can occur if you download a configuration from the MICT to a VariStep 
stepper motor card whose firmware does not correspond to the status of your MICT: 

– No values are present in the configuration for certain firmware functions. The firmware 
continues to use the preset values for these functions. 

– The configuration contains function values that are not supported by the firmware. 

If you download a configuration to the stepper motor card and are notified of functions that are 
not supported by the MICT, you should check the stepper motor card settings. Re-upload the 
configuration from the stepper motor card to the MICT. You can then see which settings are not 
transmitted to the MICT. 
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Perform a firmware update, if necessary, and/or update your MICT so that you can use all the 
functions of the VariStep stepper motor card without restriction. 
 

8.9  Configuration 
The window opens after you select the device type for a new configuration or an existing 
configuration or have uploaded one from the device. You can make changes to the configuration 
by selecting an entry from the navigation bar. The corresponding configuration data are then 
displayed in the configuration section and can be processed. The following sections will 
describe the settings and adjustments you can implement in the different areas. 
 

8.9.1 External Device 

 

To change the device type, approval for the access level Advanced Service is required. 
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Device Type 
Select the device type you wish to configure and drive with the VariStep stepper motor card from 
the drop-down list. 

– VariFuel2 
Select this option to select the VariFuel2 type from the following drop-down list that 
corresponds to the device you want to configure. Note the stepper motor revision when 
making your selection. 

– Throttle 
Select this option to select the throttle from the following drop-down list with integrated 
stepper motor (ITB) or the throttle gear (TG) that corresponds to your application. 

– Unknown 
This option corresponds to the factory setting and cannot be reassigned if the device has 
been changed once. 

– None 
Select this option if you wish to take the VariStep stepper motor card temporarily out of 
operation or store it. In addition, this option can be selected if the VariStep stepper motor 
card was configured for one device type and is then to be used for another device type. For 
this, also read the information box Changing the device type. 

  

 

Note the stepper motor revision 

The revision of the stepper motor can be identified from the nameplate on 
the stepper motor of your VariFuel2. 

VariFuel2 stepper motors whose revisions are not stated on the nameplate 
or which are supplied without a nameplate are revision A stepper motors. 
For revision A select under External Device the entry of yor VariFuel2 type 
without revision information (e. g. VF2 200-120 for a VariFuel2 of the type 
200-120 with a revision A stepper motor). 

If no VariFuel2 types with matching stepper motor revision are displayed 
under External Device, the VariFuel database of your MICT is not up-to-date. 
In this case, perform an online update. For further information, refer to the 
section Online Update Settings on page 40. 
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Changing the device type 

The process how to exchange one VariFuel2 type for another is described 
below. However, the process can also be carried out correspondingly if you 
change the device type. For example, you would now like to use the 
VariStep which you used for a VariFuel2 gas mixer for a throttle. 

Scenario:  
You have replaced one VariFuel2 gas mixer with another VariFuel2 type.  

Problem:  
After connecting the new VariFuel2 gas mixer, the stepper motor card 
performs a reference run. However, since this configuration still contains 
data from the first gas mixer, it is possible that the VariFuel2 may leave the 
traversing range and be mechanically damaged as a result, or there is a 
risk that the VariFuel2 has to be readjusted. 

Solution: 
The following procedure will help to solve the problem: 

1. Separate the first VariFuel2 from the stepper motor card. 

2. Connect the MICT to the stepper motor card. 

▸ The defective connection with the stepper motor causes an 
operating error. 

3. Switch to manual mode. 

4. Acknowledge the error via the MICT (Device -> Error Acknowledge). 

5. Change the configuration to the new VariFuel2 type. 

6. Download the altered configuration to the device. 

7. Separate the stepper motor card from the supply voltage. 

8. Connect the new VariFuel2 to the stepper motor card. 

9. Reconnect the stepper motor card to the supply voltage. 

▸ A reference run will be performed. The new VariFuel2 is then ready 
for operation. 

Tip: 
When you first configure the VariStep stepper motor card with the option 
None in the drop-down list Device Type no operating error is triggered after 
the device has been separated from the stepper motor card. You can now 
reconfigure the stepper motor card directly. 
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8.9.2 Inputs / Outputs – Control Setup 

 

The settings on the configuration page depend on the inputs and outputs used by your master 
control. In this case, refer to all information given in the relevant documentations of the control 
units. To make changes, approval for the access level Advanced Service is required. 

Selection 
– Input 

Select the input that is to be used for position setting by the higher control connected. The 
following options are possible: 

– Analog Voltage 
Position setting is achieved via an analog voltage signal. 

– Analog Current 
Position setting is achieved via an analog current signal. 

– Digital Steps/Dir 
Position setting is achieved via a digital signal. 

– Field bus 
Position setting is achieved via the ALL-IN-ONE. For this purpose the communication 
with the ALL-IN-ONE must be configured (see Miscellaneous – Communication on 
page 53) 
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– Output 
Select the analog output that is to be used by the connected master control. 

– External manual/automatic selection enabled 
Please deactivate the check box to disable the switch Auto/Manual on the stepper motor 
card. The stepper motor card may then only be put in manual mode via the MICT with the 
corresponding authorization. 

Input Voltage/Input Current 
Depending on which input is selected, you have different adjustment options available. For the 
analog inputs, enter the values for the open and closed position of the fuel ring. Here, please 
adhere to the following values: 

– Input voltage: 0 to 10 V 

– Input current: 0 to 20 mA 

Input Step Count/Step Count Configuration 
Set the Direction and the Init Position of the steps for the digital inputs. The initial position (=Init 
Position) will be approached after the reference run of the stepper motor. 

To make these settings, refer to all additional information as provided in the following note. 

 

Click this button to apply the settings of the analog input (current or voltage) to the output 
selected. If you have selected another input as output (e. g. input: current; output: voltage), the 
adjusted values are converted in accordance with the output's value range. 

Output Voltage/Output Current 
Depending on the selection, enter the relevant current or voltage values, which are to 
correspond to the open and closed position. Here, the same value ranges are applicable as with 
the analog inputs. 
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Settings of the input selected 

Analog Inputs (Current or Voltage) 
Based on the values used by your master control, you can define the values 
of the Open and the Close position for the analog inputs in the MICT. The 
value applied to the input is then converted proportionally to the values 
entered in a corresponding opening angle of the throttle or the fuel ring of 
the VariFuel2. 

Example: 

Your master control works with a power input of 4 to 20 mA. In the MICT, 
you configure 4 mA to refer to the closed position and 20 mA to the open 
position. If the current on the input is now 16 mA, the opening is 75 %. 

Digital Inputs 
In the MICT, you can define the behavior for the digital inputs DIRin and 
STEPSin. The level on DIRin determines the direction in which the fuel ring 
of the VariFuel2 or throttle move if pulses occur on STEPSin. 

Example: 

In the MICT under Direction you selected the option Logic 1 -> Open. If a high 
level is now applied on the DIRin with each pulse on the STEPSin one step is 
added to the current position. The fuel ring or throttle will then move 
gradually from the Close to the Open direction.  

   

 

Unused inputs and outputs 

Note that the terminals for the analog inputs and outputs not selected in 
the MICT must remain unoccupied. 
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8.9.3 Positions – Values 

 

Position 1/Position 2 
You can define two configurable positions using these two input fields. For this approval for the 
access level Service or Advanced Service is needed. Enter the desired opening angle of the fuel 
ring of the VariFuel2 or throttle as percentage (100 % refers to open, 0 % refers to closed). The 
openings named here can be set in manual mode using the MICT or in automatic mode using the 
digital inputs of the stepper motor card. 

For further information, refer to section Configurable Opening Angles (Position 1 and 2) on 
page 31. 
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8.9.4 Miscellaneous – Communication 

 

CAN 
Deactivate or activate the CAN interface on the device via the field CAN enabled.  

– ALL-IN-ONE (J1939) 
The protocol for communication with the ALL-IN-ONE is automatically selected upon 
activation of the CAN interface. 

– Baudrate 
Select the desired data transfer rate from the list. In the protocol ALL-IN-ONE (J1939) 
250 kBit/s and 500 kBit/s are available for selection. 

– Source Addr 
In the protocol ALL-IN-ONE (J1939) the source address can be assigned between 0 and 253. 
Please note that IDs cannot be assigned more than once. 
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Setting the transfer rate 

Please note that all devices connected with a bus must be set to the same 
transfer rate. 

  
 

8.9.5 Miscellaneous – Service Contact 
This configuration page can be viewed by all users, but changes can only be made with 
authorization for the Advanced Service access level. 

 

Contact 
In this area, you can store individual contact data. 
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8.10  Runtime Data 

 

Click on the symbol to open the window Runtime Data. The following sections 
will give you an overview of the data you can view on the individual tabs. 

You can print and record the runtime data. For this purpose, the following functions are at your 
disposal in the toolbar in the window: 

Symbol Function 

 

Prints the runtime data.

 

Prints the runtime data to a PDF file.

 

Opens the print preview.

 

Starts the runtime data trace.

 

Stops the runtime data trace.
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8.10.1 Runtime Data – Overview 

 

In this screen, you can find the following information: 

Reference Run 
The status display provides information on the reference run: 

– Green: The reference run was completed successfully. 

– Yellow: The reference run is being carried out. 

– Red: Errors occurred during the reference run. The reference point was not found. 

Manual/Auto 
The status display indicates the operation mode selected: 

– Green: The operation mode is set. 

– Yellow: A command is carried out in the operation mode selected. In automatic operation 
mode, the status display will only turn yellow if position 1 or 2 is approached. 

– Red: An error occurred in the operation mode selected. 
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Stepper Motor 
The status display indicates the condition of the stepper motor: 

– Green: The stepper motor is ready. 

– Yellow: The stepper motor is active. 

– Red: An error occurred. 

Warning/Error 
A red status display indicates that an error or a warning message occurred. The display will go 
out if the error is acknowledged via the MICT (Device -> Error Acknowledge). Please read sections 
Runtime Data – Errors on page 59 and Runtime Data – Warnings on page 58. 

Opening 
– Target 

Value that is assigned to the stepper motor card in automatic mode by the master control or 
in manual mode by the MICT or the Open/Close buttons on the device.  

– Actual 
The value shown corresponds to the percentage opening of the throttle or the fuel ring of the 
VariFuel2. 
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8.10.2 Runtime Data – Warnings 

 

The following information is provided: 

– Time Stamp 
Status of the operating hours counter at which the warning occurred. 

– Warning ID 
The warning ID is used to identify the warning. 

– Warning 
Brief description of the warning. 

You have the following options: 

– Update 
With the Update button, you can manually update the warning list displayed. If a warning 
occurs, the list is updated automatically. 

– Show in reverse order 
Please activate the checkbox to reverse the order of the listed entries. 

– Show only current entries 
Activate the checkbox to only show the entries which are still up-to-date. 
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8.10.3 Runtime Data – Errors 

 

The following information is provided: 

– Time Stamp 
Status of the operating hours counter at which the error occurred. 

– Error Id 
The error ID serves to identify the error. 

– Error 
Short description of the error. The following errors are possible: 

  

Error Description 

Interframe Step Loss Step losses on account of rough running gas mixer or rough-
running throttle 

Remedy: 
Check device for rough running. In the case of the gas mixer, 
belt tension that is too high may be responsible for rough 
operation. 



8 SETTINGS VIA THE MICT 
 

60 Rev. 11/2014 

Error Description 

Stop Step Loss Step losses on account of rough running gas mixer or rough-
running throttle 

Remedy: 
Check device for rough running. In the case of the gas mixer, 
belt tension that is too high may be responsible for rough 
operation. 

Timeout The relevant action could not be finished within the predefined 
time. 

Please inform the technical service incl. the entire error 
message. 

Shut Off Device was switched off.

Low Power IRQ Short-time drops of the supply voltage.

Remedy: 
Improve supply voltage. 

Etpu Handler Msg Queue 
Full 

Software is overloaded. Please inform the technical service.

Input Handler Msg Queue 
Full 

Software is overloaded. Please inform the technical service.

Output Handler Msg 
Queue Full 

Software is overloaded. Please inform the technical service.

CAN Handler Msg Queue 
Full 

Software is overloaded. Please inform the technical service.

Over Temperature IRQ Over temperature

Remedy: 
Improve cooling. 

Over Current IRQ The current to the stepper motor is too high.

Remedy: 
Check wiring to the stepper motor. 

  
You have the following options: 

– Update 
With the Update button, you can manually update the error list displayed. If an error occurs, 
the list is updated automatically. 

– Show in reverse order 
Please activate the checkbox to reverse the order of the listed entries. 

– Show only current entries 
Activate the checkbox to only show the entries which are still up-to-date. 
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8.10.4 Runtime Data – Diagnostics 

 

In this screen, you can find the following information: 

Operation Mode 
The operation mode section shows which operation mode (Manual or Automatic) is currently 
active and how the operation mode was adjusted. Here, there are the following two options: 

– Ctrl 
Shows if the operation mode was adjusted using the MICT or the switch Auto/Manual on the 
device (Hardware). 

– Mode 
The operation mode set is shown. 

States 
This area shows the current conditions of the stepper motor card, the stepper motor and all 
individual phases of the reference run. 

CPU Load 
Current capacity utilization of the processor. 
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Supply Voltage 
Current supply voltage of stepper motor card. 

Current Temp. 
Current temperature of board. 

Max. Temp. 
Maximum reached temperature of the board since the stepper motor card was switched on the 
last time. 

Min. Temp. 
Minimum reached temperature of the board since the stepper motor card was switched on the 
last time. 

Max. Step Loss 
Internal diagnosis parameters associated with the control of the stepper motor. If the step 
losses are too high, this will cause an error message. 
 

8.10.5 Runtime Data – Information 
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In this view, you can find an overview of the device and version data. You can also print the 
current runtime data or, in case of problems, send them to the MOTORTECH Service Department 
via fax or as a PDF file via e-mail. For fast support, we will then immediately have all required 
information. 
 

8.11  Log 

 

Click on the symbol to open the window Log. This window is only available to 
users with authorizations starting at the access level Advanced Service. 

 

The window Log serves to support error diagnostics by MOTORTECH.  

– Automatic scrolling 
If the function is active, the view panel focuses on the latest message. 

– Log level 
The selection of the log level is specified by MOTORTECH if needed. 

– Write Log to File 
This checkbox activates or disables, respectively, the saving of the logged data in a selected 
file. If the function is disabled, the logged data are merely shown on the display. 

– Select File 
With this button, you can select a file to which you want to save the logged data. 
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If you are prompted to create a log file in the case of a service request, proceed as follows: 

1. Open the window Log via the toolbar or the menu bar. 

2. Select a path with the Select file button and enter a file name for the log file. 

▸ If the file does not yet exist, it is automatically created with the extension .log. 

3. Activate the checkbox Write log to file. 

4. Select the level specified by MOTORTECH from the Log level list. 

5. Leave the window open. 

▸ The log messages are logged both in the window and in the selected file. 
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9.1  Firmware Update 
Using the MOTORTECH Flash Tool, you can perform a firmware update for the stepper motor card. 
The provided CD-ROM comprises this program. 

Install MOTORTECH Flash Tool 
This is how to install the MOTORTECH Flash Tool: 

1. Start the installation. 

– Insert the CD-ROM into the CD/DVD drive of your PC. If the Autostart function is enabled 
for the drive, cancel the installation program for the MOTORTECH Integrated 
Configuration Tool if necessary. 

– Copy the file MOTORTECHFlashTool-x.x.x.zip (e. g. MOTORTECHFlashTool-0.8.3.zip) to 
your PC. 

– Unzip the file. 

– Start the installation routein by running the unzipped file setup.exe. 

2. Install the program. 
Follow the installation process instructions. Note that the license agreement terms must be 
accepted before using the MOTORTECH Flash Tool. If the terms are not accepted, the 
installation cannot continue. 

3. If it has not yet occurred, install the USB driver by executing the file on the CD ROM 
CDMxxxxx_Setup.exe (e.g. CDM20824_Setup.exe) . 

▸ You have now installed the MOTORTECH Flash Tool and can now connect your PC to the 
stepper motor card via the USB interface. 

Menu Bar and Toolbar 
After launching the MOTORTECH Flash Tool, the following functions are available to you via the 
icons on the toolbar and the entries in the menu bar: 

Symbol Menu Function 

 

File -> Open Opens a firmware file.

  File -> Quit Exits the program.

 View -> Extended file information 
view 

Fades in / out additional information of the 
firmware file. 

  View -> Extended connection 
settings 

Fades in / out additional information and 
settings of the connection to the device. 

 

View -> Reload file Reloads the file information of the selected 
firmware file. 
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Symbol Menu Function 

 

Device -> Search devices Restarts the search for connected devices.

 

Device -> Flash device Starts the update process or downgrade 
process. 

  Settings -> Language Opens the window Select Language in 
which you can change the interface 
language of the program. 

  Help -> Help Opens the online help function.

  Help -> About MOTORTECH Flash 
Tool  

Opens detailed information on the 
program. 

 

Start Firmware Update 
  

 

Access control for firmware update 

If you have activated the access control for the device, you need the PIN for 
the level Master for the firmware update. For more information read the 
section Access Control of the Stepper Motor Card on page 41. 

   

 

Backup the existing configuration 

Your device's configuration may be lost if the firmware update is not 
performed properly. Always backup the existing configuration via the MICT 
prior to performing an update. For further information please refer to the 
section Working with Configurations on page 43. 

  

To start the firmware update, proceed as follows: 

1. If an MICT is connected with the stepper motor card, disconnect this connection. 

2. Launch the MOTORTECH Flash Tool via Start -> Programs -> MOTORTECH -> MOTORTECH Flash 
Tool -> x.x.x (e. g. 0.8.3) -> MOTORTECH Flash Tool. 

▸ The MOTORTECH Flash Tool will now start. 

▸ The software automatically checks all ports for connected devices. 
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3. Check in the area Status under Device whether your device was correctly recognized. 

▸ If the MOTORTECH Flash Tool does not recognize a device that is connected to your PC 
via the USB interface, you can usually still carry out a firmware update. To do so, 
observe the instructions in the information windows of the MOTORTECH Flash Tool for 
the following steps. 

4. In the area File using the button Select select the desired update file. 

5. By reading the displayed file information, ensure that the update file is correct for your 
device. 

6. Start the update process using the Flash button or using the menu or toolbar. 

▸ The stepper motor card will be restarted automatically. 

▸ Now, a window opens informing you about the firmware version currently used on your 
stepper motor card and also about the relevant update version. 

7. Please confirm with Yes to proceed with the update process. 

▸ Now the update will start. 

▸ If the firmware update was successful, you will see a relevant message. 

▸ Now, the stepper motor card will initiate a reference run. 

8. After a successful firmware update, check all configuration data. 

  

 

Downgrade process 

The process for a downgrade is largely the same as the update process. You 
will only be informed that a new firmware has been installed on the device. 
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Help with connection problems 

If a correctly connected device is not found during the automatic search, 
this can, for example, be because too many communication interfaces are 
assigned and must be checked. In this case an interface from the drop-
down list Port in area connection can be selected and thus specified.  

If the desired port is not yet displayed in the list or if the problem should 
continue, an adjustment of the time-outs for the connection helps. The 
time-out settings are displayed in the main view by the following entry in 
the menu bar: View -> Extended connection settings. 

Enter the following settings: 

– Update Request Timeout 
Adjustment range: 1000 ms to 10000 ms, default value: 3000 ms. 
An extension of the time-out can be an advantage, especially with 
connection problems that occur because the computer has many 
assigned ports. 

– Start Timeout 
Adjustment range: 1000 ms to 10000 ms, default value: 3000 ms. 
A time-out change can be an advantage, especially with connection 
problems that occur because the communication between the computer 
and the device has been interrupted. 
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10.1  Troubleshooting 
If the stepper motor card detects an error, the LED status blinks red. You can find details about 
status signaling in the following information box. In automatic mode, the digital output 
ERRORout is also activated in the event of a fault and the corresponding LED lights up. Using the 
MICT you can see the type of error occurred. For this, refer to the section Runtime Data – Errors 
on page 59. 

   

 

Status signaling 

The status of the VariStep stepper motor card is signaled via the LED Status.

– Error-free  operation: flashes green 

– Warning: flashes orange 
Warnings are reset by a reference run or by downloading a 
configuration to the device. For example, warnings are triggered by: 

– VariStep stepper motor card is unconfigured. 

– Device connected was changed. 

– Over-temperature or over current error confirmed by MICT. 

– Error: flashes red 
Error can be confirmed via MICT, simultaneously pressing button Open 
and Close or by the external reset signal. Errors can for example be 
caused by: 

– Step loss 

– Over temperature 

– Low voltage 

– Over current 

  
 

10.2  Possible Faults 
Low power 
The supply voltage has fallen under 11 V. 

Potential causes: 

– The power supply is dimensioned too small. 

– The battery is worn out. 

– The wiring for the power supply is defective. 

– The wiring for the power supply is routed incorrectly. 
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Step loss 
The steps prescribed by the stepper motor card have not been carried out by the stepper motor. 

Potential causes: 

– The belt tension of the VariFuel2 is too high. 

– The fuel ring of the VariFuel2 or throttle is stuck (e.g. due to deposits). 

– The wiring to the stepper motor is defective or incorrect. 

– The stepper motor is defective. 

Over temperature 
The temperature of the board of the stepper motor card has been exceeded. 

Potential causes: 

– The ambient temperature is too high. 

– Air circulation around the device is insufficient. 

Reference run failed 
It was not possible to determine the reference point of the stepper motor. 

Potential causes: 

– The belt tension of the VariFuel2 is too high. 

– The fuel ring of the VariFuel2 or throttle is stuck (e.g. due to deposits). 

– The wiring to the stepper motor is defective or incorrect. 

– The stepper motor is defective. 

Over current 
The current to the stepper motor is too high. 

Potential causes: 

– The wiring to the stepper motor is defective or incorrect. 

– The stepper motor is defective. 

– The stepper motor card is defective. 

Device does not react 
The throttle connected or gas mixer connected does not react to the signals of the stepper motor 
card. 

Potential causes: 

– The connection between the stepper motor and throttle or gas mixer has been interrupted. 
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10.3  Acknowledging Faults 
In manual mode, you have the following options for acknowledging operating errors: 

– By means of the function Error acknowledge in the MICT 

– By pressing the Open and Close buttons simultaneously 

In automatic mode, you have the following options for acknowledging operating errors: 

– The master control sends a signal to the digital reset input 

– By pressing the Open and Close buttons simultaneously 

– By means of the function Error Acknowledge in the MICT 

Critical errors can only be acknowledged by switching the device off and on. 

  

 

Error confirmation in automatic operation 

If the VariStep stepper motor card is in automatic mode and an error should 
immediately reoccur after the acknowledgment of this error via the MICT, 
switch over into the manual mode before re-acknowledging the error again. 
After you have acknowledged the error, you can correct a defective 
configuration and transfer it to the device via download. 

 
 

10.4  Customer Service Information 
You can reach our customer service during business hours at the following phone and fax 
number, or by e-mail: 

Phone: +49 5141 93 99 0 

Fax: +49 5141 93 99 99 

Email: service@motortech.de 
 



10 DISTURBANCES 
 

72 Rev. 11/2014 

10.5  Returning Equipment for Repair / Inspection 
To return the device for repair and inspection, obtain a return form and return number from 
MOTORTECH. 

Fill out the return form completely. The completely filled out return form guarantees fast, 
uncomplicated processing of your repair order. 

Send the device and the return form to one of the two addresses below or to the nearest 
MOTORTECH representative: 

 
MOTORTECH GmbH 
Hogrevestr. 21-23 
29223 Celle 

Germany 

Phone: +49 5141 93 99 0 
Telefax: +49 5141 93 99 98 

www.motortech.de 
motortech@motortech.de 

MOTORTECH Americas, LLC
1400 Dealers Avenue, Suite A 
New Orleans, LA 70123 

USA 

Phone: +1 504 355 4212 
Telefax: +1 504 355 4217 

www.motortechamericas.com 
info@motortechamericas.com 

 
 

10.6  Instructions for Packaging the Equipment 
For return shipment, equipment should be packaged as follows: 

– Use packaging material that does not damage the equipment surfaces. 

– Wrap the equipment with sturdy materials and stabilize it inside the packaging. 

– Use sturdy adhesive film to seal the packaging. 
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11.1  Spare Parts and Accessories 
For spare parts and accessories, please refer to our current Product Guide, which is available for 
you to download on the Internet at www.motortech.de. 
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WE UPGRADE GAS ENGINES 
Original MOTORTECH Accessories for Stationary Gas Engines 

As a supplier, MOTORTECH develops, produces and distributes 
accessories as well as spare and wearing parts for nearly all kinds of  
stationary gas engines worldwide: Ignition control and monitoring, 
industrial  
spark plugs and high tension leads, wiring systems and  
gas regulation– from detonation to speed control and  
complete gas engine management. On-site support and special training  
courses complete our service. 
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